Help us to improve our website!

We want to inspire you for our UCC solution! To do this, we use cookies to provide you with an optimal and personalised website experience. Clicking on "Accept all" allows us to process this data and share it with third-party providers in accordance with our privacy policy. Here you can also adjust the cookie settings at any time.
Technically necessary cookies
Statistics
Comfort
Accept all
Save selection

Why does my configured SIP gateway not turn "green"?

 
 

A SIP gateway to the PBX has been configured to use features such as AnyDevice. However, the SIP gateway remains on "yellow" after saving and does not turn "green". What could be the reason for this?


1st cause: The SIP gateway does not reach the PBX (or vice versa).

To check if the SIP gateway can connect to the PBX, check the SIP connection using the Wireshark program. Install Wireshark on the XPhone Connect server and follow the steps below:


Start Wireshark as administrator.

  • On the start page you will be offered the Ethernet connections of the server
  • Double click on the Ethernet interface where the network connection is established (usually "Ethernet")
  • Wireshark should now capture the packets
  • At the top you will find a bar 'Apply display filter ... <Ctrl-/>'
  • Type there "sip" (without quotes, all lowercase), and press 'Enter'
  • Now only the SIP communication will be listed
wireshark_sip

After a maximum of one minute, you should find packets sent from the XPhone Server to the PBX.

These packets have the following structure in the "Info" field:

Request: OPTIONS sip:*ip-address*:*port*;transport=udp

wireshark_200ok

Only when these messages are answered by the PBX with a "Status: 200 OK" message does the connection exist.

If the "Request" is not followed by a response from the PBX, either the "Request" packet does not reach the PBX or the "200 OK" message does not reach the XPhone server.

In this case, the "Request" messages in Wireshark accumulate among each other (a new attempt to establish the connection should be made after 30 seconds at the latest).


Solution:

Check the IP address configuration in your SIP gateway so that the packets are sent from XPhone Server to the correct destination, as well as the network so that for example no firewall intercepts the packets.


2nd cause: The IP address / ports in the SIP gateway for softphone are configured incorrectly.

Please make sure in the configuration that the IP address 127.0.0.1 is not changed. The IP address must also not be changed to "localhost".

sipconnectionxccxpc

In addition, if there are multiple SIP gateways, it must be ensured that unique ports are assigned in each SIP gateway. Here, it is usually possible to count up:

  • SIP-Gateway #1 -> Ports: 4901 & 4900
  • SIP Gateway #2 -> Ports: 4903 & 4902
  • SIP Gateway #3 -> Ports: 4905 & 4904
  • etc.


3rd cause: The local IP socket is already occupied by XCAPI.

Similar to the 1st cause described, a Wireshark trace should be opened. If no packets are sent from the XPhone server to the system even after waiting for a while, XCAPI is most likely involved and already occupies the local IP socket configured in the SIP gateway.

If this is the case, the SIP gateway cannot access its local interface and thus cannot be fully initiated.


Solution:

To do this, change the local IP socket in the SIP gateway configuration in the connection settings to the PBX:

sipconnectionxccpbx

Either give the XPhone server a second IP address or configure a different port.

We recommend that you start with port 5064 when configuring the port, as this is certainly free (port 5061 could possibly still be occupied by XCAPI).


Important: Do not forget to consider this setting also on the PBX!

Subscribe to our Newsletter

 
 
 
 
 
 
 

Thank you for subscribing. To confirm your subscription, please click the link in your registration email.

 
 

An error occured. Please try again.