Warum wird mein konfiguriertes SIP-Gateway nicht "grün"?

 
 

Ein SIP-Gateway zur Telefonanlage wurde konfiguriert, um Features wie z.B. AnyDevice zu nutzen. Das SIP-Gateway bleibt jedoch nach dem Speichern auf "gelb" und wird nicht "grün". Woran kann das liegen?


1. Ursache: Das SIP-Gateway erreicht die Telefonanlage nicht (oder umgekehrt)

Um zu prüfen, ob das SIP-Gateway eine Verbindung zur Telefonanlage aufbauen kann, prüfen Sie die SIP-Verbindung über das Programm Wireshark. Installieren Sie Wireshark auf dem XPhone Connect Server und befolgen Sie die folgenden Schritte:

  • Starten Sie Wireshark als Administrator
  • Auf der Startseite werden Ihnen die Ethernet-Verbindungen des Servers angeboten
  • Doppelklicken Sie auf die Ethernet-Schnittstelle, auf welcher die Netzwerkverbindung aufgebaut wird (i.d.R. "Ethernet")
  • Wireshark sollte nun die Pakete aufnehmen
  • Oben finden Sie eine Leiste 'Anzeigefilter anwenden ... <Ctrl-/>'
  • Geben Sie dort "sip" (ohne Anführungszeichen, alles klein geschrieben) ein, und drücken Sie 'Enter'
  • Nun wird nur die SIP-Kommunikation aufgelistet


wireshark_sip

Nach spätestens einer Minute sollten Sie nun Pakete vorfinden, die vom XPhone Server zur Telefonanlage geschickt werden.

Diese Pakete besitzen im Feld "Info" folgende Struktur:

Request: OPTIONS sip:*ip-address*:*port*;transport=udp

wireshark_200ok

Erst wenn diese Nachrichten von der Telefonanlage mit einer Nachricht "Status: 200 OK" beantwortet werden, besteht die Verbindung.

Sollte auf den "Request" keine Antwort der Telefonanlage folgen, so erreicht entweder das "Request"-Paket die Telefonanlage nicht, oder die "200 OK"-Meldung erreicht den XPhone Server nicht.

In diesem Fall häufen sich die "Request"-Nachrichten im Wireshark untereinander (ein neuer Versuch, die Verbindung aufzubauen, sollte spätestens nach 30 Sekunden erfolgen).


Lösung:

Prüfen Sie die IP-Adress-Konfiguration in Ihrem SIP-Gateway, sodass die Pakete vom XPhone Server an das korrekte Ziel geschickt werden, sowie das Netzwerk, sodass z.B. keine Firewall die Pakete abfängt.


2. Ursache: Die IP-Adresse / Ports im SIP-Gateway für Softphone sind falsch konfiguriert

Achten Sie bitte hier in der Konfiguration darauf, dass als IP-Adresse die 127.0.0.1 nicht verändert wird. Die IP-Adresse darf auch nicht auf "localhost" geändert werden.

SIP-Gateway IP-Adresse- / Port-Konfiguration

Zusätzlich muss sicher gestellt werden, falls es mehrere SIP-Gateways gibt, dass in jedem SIP-Gateway eindeutige Ports vergeben werden. Hier kann i.d.R. hoch gezählt werden:

  • SIP-Gateway #1 -> Ports: 4901 & 4900
  • SIP Gateway #2 -> Ports: 4903 & 4902
  • SIP Gateway #3 -> Ports: 4905 & 4904
  • etc.


Newsletter abonnieren

 
 
 
 
 
 
 

Vielen Dank! Bitte schließen Sie Ihre Newsletter-Anmeldung ab, indem Sie den Link in unserer Bestätigungs-Mail klicken.

 
 

Leider ist ein Fehler aufgetreten. Bitte versuchen Sie es erneut.



Cookies ermöglichen die bestmögliche Darstellung unserer Dienste. Mit der Nutzung der Seiten von C4B Com For Business erklären Sie sich damit einverstanden, dass wir Cookies verwenden. Mehr Infos