Warum kommt kein Ruf zu Stande, wenn jemand angerufen wird, der auf einen Follow-Me Teilnehmer umleitet?

 
 

Problem:

Leitet ein Benutzer auf einen Teilnehmer um, der Follow-Me aktiv hat, so kommt der Ruf nicht zu Stande wenn der Benutzer angerufen wird. Der Ruf wird vom XPhone Server abgelehnt.


Ursache:

Standardmäßig wird eine zentrale AnyDevice-Rufumleitenummer konfiguriert, auf welche jeder Follow-Me Teilnehmer umleitet, um Follow-Me zu aktivieren. Damit der XPhone Server den Ruf annehmen kann, muss er den Follow-Me Teilnehmer erkennen, der den eingehenden Ruf auf den XPhone Server umgeleitet hat. Dies erfolgt anhand des "Diversion"- bzw. "History-Headers" im SIP-Invite, welcher von der Telefonanlage zum XPhone Server geschickt wird. 

Hierzu nähere Informationen: https://www.c4b.com/de/knowledgebase/xcc/xcc-follow-me-probleme-analysieren.php

Leitet nun ein Benutzer auf einen Follow-Me Teilnehmer um, signalisiert die Telefonanlage im "Diversion"-Header nicht die Rufnummer des Follow-Me Teilnehmers, sondern des Benutzers, der auf den Follow-Me Teilnehmer umgeleitet hat.

Der XPhone Server lehnt aus diesem Grund den Ruf ab, da er für den umleitenden Benutzer kein Follow-Me Gerät finden kann. Der eigentliche Follow-Me Teilnehmer wird im SIP-Invite der Telefonanlage nicht signalisiert, weswegen das Verhalten dieser Methode nicht von C4B behoben oder umgangen werden kann.


Lösung:

Um dieses Verhalten zu lösen, muss Follow-Me über eine andere Methode konfiguriert werden. 

Diese andere Methode ist, dass die Follow-Me Teilnehmer nicht auf eine zentrale Rufnummer umleiten, sondern auf ein ausgewähltes Präfix, auf welches die eigene Nebenstelle folgt. Diese Umleitung auf das Präfix muss genauso wie die zentrale Rufnummer auf den SIP-Trunk des XPhone Connect Servers geroutet werden. In der Regel kann dafür der bestehende Eintrag in der Telefonanlage bearbeitet werden.

Folgende Anpassungen müssen Sie im XPhone Server treffen.


1) Bearbeiten Sie das betroffene SIP-Gateway in der Administrationsoberfläche unter Systemeinstellungen > Telefonie > Gateways > SIP

2) Entfernen Sie die zentrale AnyDevice-Rufumleitenummer im SIP-Gateway und deaktivieren Sie die Funktion, indem Sie den Haken entfernen

Zentrale AnyDevice Rufnummer entfernen

3) Konfigurieren Sie das XccGatewayInPrefix in den 'Erweiterten Einstellungen' des SIP-Gateways. Geben Sie dazu das gewünschte Präfix ein (hier wurde als Beispiel das Präfix 99 gewählt)

XccGatewayInPrefix konfigurieren

4) Passen Sie die Interne Rufnummernlänge in Ihren Wahlparametern in der Administrationsoberfläche unter Systemeinstellungen > Wahlparameter an. Dies muss sowohl im Wahlparameter Ihres Festnetzgateways sowie des SIP-Gateways angepasst werden. Die Interne Rufnummernlänge muss mindestens Präfix+Nebenstelle betragen (z.B. Präfix+Nebenstelle 99+123, beträgt die Interne Rufnummernlänge mindestens 5)

5) Passen Sie die Telefonanlage so an, dass Umleitungen auf das ausgewählte Präfix+Nebenstelle möglich sind, und Rufe auf das Präfix+Nebenstelle auf den SIP-Trunk des XPhone Servers geroutet werden

6) Die Benutzer müssen nun ihre XPhone Connect Clients neu starten, damit die Änderungen wirksam werden

Näheres zur Konfiguration des XccGatewayInPrefix finden Sie hier: https://help.c4b.com/de/xphone-connect-8/admin/#5831.htm

Die Follow-Me Teilnehmer leiten nun nicht mehr auf eine zentrale Rufnummer um, sondern auf das Präfix+Ihre eigene Nebenstelle. Diese Umleitung auf das Präfix+Nebenstelle baut der XPhone Server automatisch zusammen, wenn Follow-Me bei konfiguriertem XccGatewayInPrefix aktiviert wird.

Wenn nun ein Benutzer auf einen Follow-Me Teilnehmer umleitet, wird der Ruf korrekt zum AnyDevice des Follow-Me Teilnehmers zugestellt. Grund dafür ist, dass nicht mehr der "Diversion"-Header im SIP-Invite berücksichtigt wird, sondern der "To"-Header, in welchem die Telefonanlage die korrekte Rufnummer Präfix+Nebenstelle signalisiert.


Achtung:

Für eine Anrufübername (bspw. via Teampanel) muss zusätzlich der Parameter XccUseDirectRedirecting mit dem Wert 1 gesetzt werden.

Newsletter abonnieren

 
 
 
 
 
 
 

Vielen Dank! Bitte schließen Sie Ihre Newsletter-Anmeldung ab, indem Sie den Link in unserer Bestätigungs-Mail klicken.

 
 

Leider ist ein Fehler aufgetreten. Bitte versuchen Sie es erneut.



Cookies ermöglichen die bestmögliche Darstellung unserer Dienste. Mit der Nutzung der Seiten von C4B Com For Business erklären Sie sich damit einverstanden, dass wir Cookies verwenden. Mehr Infos