Problem:
Wenn ein Agent sein
CTI-Device verwendet, werden Anrufe nicht durchgestellt. Der Anmeldestatus im
Connect Client des Agenten springt von „Bereit“ auf „Abgemeldet“, ggf. auch mehrfach.
Ursache:
Die Innovaphone (oder ggf. andere TK-Systeme) kann mit dem vom uns verwendeten
E.164 Format, das wir auf das Hardphone schicken, nicht umgehen.
Lösungswege:
Lösung 1)
Änderung des
Rufnummernformats auf intern:
Hinterlegen Sie im SIP-Trunk zur Innovaphone (Telefonie > Gateways > SIP)
bei "Erweiterte Einstellungen" den Parameter
XccCTIAgentCallingNumberFormat (Groß- und Kleinschreibung ist zu beachten) und
vergeben Sie den Wert 4
Hier die möglichen Werte mit Bedeutung:
1 - in E164 (Default)
2 - international mit 00 anstelle von +
3 - international ohne 00
4 - interne Extension
Lösung 2)
Änderung der Konfiguration innerhalb der Innovaphone:
Im XCC bleibt der Defaultwert für XccCTIAgentCallingNumberFormat auf 1 (E.164),
d.h. es muss im XPhone Connect Server nichts gesetzt werden. Im Gateway der Telefonanlage
welches zum C4B XCC geht, muss der Wert CDPN In auf International 49xxxxxxx
gesetzt werden, damit der Amtskopf auf die Nebenstelle runtergekürzt wird. Dadurch
wird die Rufnummer korrekt angezeigt.
In
der Detailansicht der Warteschlange werden Anrufer nicht oder nur sporadisch
aufgelöst
Es geht um diese Ansicht:
Das Verhalten ist gefixt und wird derzeit getestet. Mit einem Patch ist die nächsten Tage zu rechnen.
Folgenden Patch herunterladen: https://dev.c4b.de/downloads/VDirWebClient.exe